Call screening

All of a sudden, the call screening doesn’t show up on the screen when a call comes in. I didn’t change any settings, and it worked before. I checked the settings, and I have it turned on per Google’s instructions. Has anyone seen this behavior, and more importantly, and suggestions on how I can fix it?

Sharing is caring!

Leave a Reply