Can recover data/restore factory rom via adb/fastboot/PC only (w bootloader locked)?

Uncategorized
in brief:
the data should be there on the phone, so there’s hope it should be easier to recover than deleted data but i run out of ideas how to get adb to find and pull it… maybe a more advanced user has better knowledge (better commands or tools)
adb devices and fastboot devices communicate with phone, so i have all drivers installed, i can only tackle with it via usb from windows 7 based computer

the detailed story:

i have a huawei g620s-L01, stuck in bootloop and also "volume down" button does nothing… the bootloader is locked and huawei seems to have stopped providing unlock codes…the touch works but is shattered so i was told repair the button is not an option…

i can boot it into recovery mode using "volume up + power" but i can’t use the recovery menu due to the dead "volume down"

from recovery menu i can only "reboot system now" but that re-enters the bootloop,

also i get bootloop if i try to boot into download mode via adb command

i can use some adb commands (i say some because some return errors, others say i don’t have permissions)

i can boot into fastboot via adb command too…i can not find my dcim folder or any data folder to use the pull commnad, i tried the generic commands to pull sdcrd or dcim or all files with *.jpg

the user data is not accesible, i could browse some system directories but they did not contain my files via cd commands

i found some threads saying maybe i need mount or root commands
but trying to mount partitions or access su via adb also gives errors

su is not found, i do remember there was a su when android was working on the devices but is useless if i can’t find/access it

i found the factory rom and some tools to try to restore rom to the phone due to claims that same rom might find my data, but the tools failed to start due to locked bootloader

i also tried several versions of full android sdk (old and new) trying to find "monitor or file browser" tools but the menu is not there…perhaps it will not activate those tools when device is in fastboot/recovery modes 🙁

i also found a 3rd party full android browser but can’t connect with it either

also recovery softs are useless, they need a working android to try to recover anything…some recovery softs claimed they can fix bootloop but don’t support my device

free tools that try to unlock bootloader also failed

so at this point i am running out of things to try

Sharing is caring!

Leave a Reply