Can’t acces recovery mode and stuck at bootscreen

Legacy Android & Other OS's
So,

I have an LG Spirit H420. This is my old phone and didn’t use it in the last two years. But recently I found it and turned it on worked, but it was super slow.

The problem occurred when the next day I turned on again to save some stuff from it. It didn’t turn on, the LG logo appears on the screen, and the ‘powered by android’ title, then the screen goes black and the LG logo appears again with animation and that’s it. I left it at first because I thought it’s old and it needs some time. After two hours still saw the LG logo with the animation.

Got suspicious it doesn’t gonna start so I took out the battery and put it back again then turned on but with the same result after some time passed. Tried this a couple more times with no success.

I tried factory resetting the phone by accessing the hard reset menu. It starts the process but after rebooting the phone, the same situation. Only the LG logo with the animation. I tried this a couple of times as well, again with no success.

At this point, my only reasonable thing that came to my mind is, to go in recovery mode and see what can I do there. I searched for the button combination(volup + power button) nothing happened. Tried releasing when the logo appears, tried to keep pushing, tried to release for a sec when the logo appears. I tried every possible combination that I found online but none of them works. There was one try when the phone actually did something by pressing only the volup button and during that connecting to a PC. This would result in reaching download mode if I’m correct, but the phone just shows a red warning sign with a "Your Device is corrupt. It can’t be trusted" message.

I check with "adb devices" and "fastboot devices" but couldn’t get anywhere, none of them recognized the device. The phone needs to be in fastboot mode or recovery mode or download mode to work and recognize, but I can’t reach any of them.

My last chance to revive the phone I guess is manually updating the firmware or manually setting the firmware back to the factory one. but if I’ not wrong I’m only able to do through recovery mode. Or another mode(I lost track which one is which).

I read something about flashing the ROM or something, I don’t know what this means or how to do it.

So my phone is dead? Am I missing something? How can I change the firmware if I can’t access the mode I have to? Is my only option flashing the ROM? But how?

Thanks for your time 🙂 and sorry for any bad English or hard to understand phrases

Source

Sharing is caring!

Leave a Reply