FNB Banking App

Uncategorized
Hey All,

I have a Samsung Galaxy Note 3 running Android 5.0

The FNB Banking app has been working without any problems for a loooong time but, as of the ~1 update, the update started to fail to install. I would get:

"This app is not compatible for any of your devices"

I thought this was most likely because my phone is old and still running Android version 5.0 which maybe no longer supported by FNB app. So, as I cannot get around using the app, I decided to factory reset the device.

After all of that, the problem persists. I read some articles online and some people suggested clearing the Play store cache, as well as uninstalling all updates to Play store, reboot the phone, and then try again. I did this and I still get the same error when trying to download the app.

So, I went and bought a new Samsung Galaxy Note 20 Ultra which runs Android 10.0 and did a sim swap but the problem persists. Anyone else seen this?

Thank you in advance!

Another weird thing I am noticing, is that if I go to the play store on my laptop, navigate to the FNB app, the button states "installed". If I click it, it shows that the FNB app is already installed on my device but, it is not. This seems to point to the possible reason for the error I am getting. I have cleared data and cache for the Play store app, I have also uninstalled all updates for the Play store and restarted the phone but, the same thing keeps happening.

Sharing is caring!

Leave a Reply