Galaxy A90 constant prompt for wi-fi sign-in

Uncategorized
I live in a house with a wi-fi mesh system (BT Whole Home) with four disks sharing the same SSID. My previous phone was a Samsung Galaxy A70, and I was easily able to set it up so that it seamlessly reconnected to wi-fi as I passed around the house from the area controlled by one disk to another.

My new Galaxy A90, however, won’t do this, whatever settings I use – it either pings and pops up to tell me that it has signed on to the network (which I can sort of live with), or prompts me to sign in (which I can certainly *not* live with!). I have deselected as many options as I can, but the behaviour persists – I have Wi-Fi and Auto Reconnect switched on, and also Turn on Wi-Fi automatically and Hotspot 2.0 ("Automatically Connect to Hotspot 2.0 Wi-fi networks"), but the following are off: Phone visibility, NFC and payment, Flight Mode, Advanced Calling and Messaging, Nearby device scanning.

I also switched off ‘Switch to Mobile Data’. The reason for this is as follows: when I moved through the house – if this option was switched on – the instant another disk picks up the signal, the phone would switch to 4G, and almost immediately prompt me to sign in to the wi-fi network. I should point out two things here –

1. My A70 never displayed (and still doesn’t) any of the above behaviours, moving seamlessly from one disk’s area to another;
2. With ‘Switch to Mobile Data’, my A70 would just do exactly that where necessary (e.g. in rural areas away from home) and then get me back to Wi-fi as soon as I got in range. Absolutely problem-free (and notification-free, too). Could somebody tell me how to get my A90 to behave in the same way?

Incidentally, for the purposes of diagnosing the cause of the A90’s behaviour, I had also switched off the wi-fi on the A70, just in case that had a bearing on the problem.

I’d very much value anybody’s guidance in this matter.

Sharing is caring!

Leave a Reply