Galaxy i9305 used with Alfred app now unresponsive, Help!

Uncategorized
Camera (my i9305) went "offline" yesterday.
Checking it today, it displayed the "Samsung GALAXY SIII" screen, the only change I could achieve was to see the battery icon in grey despite the charger being attached.

Opening the phone, I found the battery was blown, so I replaced it with a "new" one, it had not been previously used so may need charging but only the two screens above were once more displayed despite charger attached.

Pressing and holding power, Volume Up and home buttons,I somehow achieved a screen that warned me that installing a custom ROM was not recommended!
Declining this option by pressing the Volume Down button, I was returned to the two previous screens!

Another multi button attempt showed a poorly Android robot with the door open and the "working" icon displayed, …eventually it showed many lines of red text, finally offering several options:-
Boot from Cache
Boot from external source….?
Re-boot
Being just three I can remember.
I tried Boot from Cache first, unsuccessful
Next I tried just plain old "Re-boot", again unsuccessful.

How do I revive my phone?
Any help appreciated, thanks

Sharing is caring!

Leave a Reply