Galaxy Watch 3 always on screen not working

Uncategorized
I have the always on screen turned on. It works until I palm the watch to shut down the active screen. On my Wear OS watch this just turns off the active screen returning to the always on display. With my GW3 it turns off the screen completely. After I palm the screen the always on display quits working.

Is there a setting for the palm feature to adjust its function or turn it off? I’ve searched through the setting and haven’t found one.

Is my brand new watch glitching and needs a reset?

I need the always on screen for work. So it not working properly is a deal breaker. I could also use a simple watch face (one with digital 24hr time, date, and battery) that keeps a second hand when in always on mode. Digital watch makers have not been very friendly towards health care where we need a second hand/display.

I’d appreciate any help that I could get.

Thank you!

Sharing is caring!

Leave a Reply