I bricked my Redmi9. Is there any way of fixing it?

Uncategorized
Hello. I have (had?) a Xiaomi Redmi 9 (Lancelot). I installed the Havoc OS GSI and it worked perfectly. The nightmare came when I tried to root the phone, something went wrong and I could just get into the bootloader and recovery. I used XiaoMiTools to unbrick the phone, but it threw an error while trying to do so. Now my phone has been the last hours in a bootloop where it only shows the Redmi logo and after seconds, it reboots just for it to show the Redmi logo again…
I used to be able to access the fastboot menu and even recovery, but now even when I try pressing all the button combinations for it, it just does not seem to work. My PC used to show it on the Device Manager, but not anymore (I don’t really know if this has to do anything with the drivers, as the ADB can’t seem to find it either).
I don’t really think there is a solution to this, but I thought that as a last option I could ask for your help, so here I am. If you have any doubts, just tell me, thanks.

Sharing is caring!

Leave a Reply