I lost my google tab and can’t sign in to play store after updating google services

Ask a Question
When I updated my software, it says I have the latest version for current OS. But my android version is still 6.0

I wanted to update to at least 7.0, so I tried to force OTA update by clearing the google services framework. Didn’t work. Then I tried joining as a beta tester for google services. Still no update. So I sideloaded the latest version of google services (I think it’s 20.33.14) from apkmirror, and there lies the problem.

After installation, I couldn’t sign in to google play and I lost my google tab in accounts & sync. And I couldn’t find google services in my Apps.

It’s making me regret sideloading. I chose the 203314019 variant since it’s the most compatible to my device. I have lg k10 k430. Android version 6.0. (I chose nodpi to be safe).

I would really like to avoid doing factory reset, though I have back up.

I tried to clear the cache and data on google play (since I couldn’t find google play services). Then restart. Still nothing. I still couldn’t sign in. (And by that I mean it won’t open even if I tap the ‘sign in’. It stays frozen). Any ideas?

Source

Sharing is caring!

Leave a Reply