My Android 11 Zenfone 6 (ZS630KL) failed to detect 5Ghz WiFi AP suddenly

Uncategorized
Starting from 2 days ago, my Zenfone 6 failed to detect any 5Ghz WiFi AP. Only 2.4Ghz APs were shown on the list after turning on WiFi. I didn’t change any setting or download new applications recently. One day I went home and turned on WiFi and found that my phone was connected to my router’s 2.4 Ghz. That’s how the story begins.

My router has different SSID for 2.4Ghz and 5Ghz. Other devices can show/connect both of them, but mine can’t. I tried in a different wireless network environment (a.k.a. the router in my office) as well. Same result, so router should not be the one to be blamed.

Tried to use some WiFi Analyzer applications to check the WiFi channel graph as well. Only 2.4Ghz can be seen. Nothing shown under 5Ghz graph.

Below methods were tried but have no luck:

– Reboot my phone
– Reboot the routers
– Reset the wireless setting on my phone
– update the firmware of my phone
– Enter the 5Ghz SSID manually
– Try to connect the 5Ghz by scanning the QR code

Here is some reminders:
Yes my phone is compatible with 5Ghz. I had kept connecting to it since day 1.
No Cache Wipe under recovery mode.
No Wi-Fi Frequency Band option in the WiFi setting in my phone.
Some say changing the 5Ghz channel in the router setting should work. It doesn’t work for me. Maybe that’s because I didn’t try one channel by one channel, but I don’t think that is the issue about my router. My phone failed to search ANY 5Ghz AP, not a specific one.

Please kindly send some helps if you come up some ideas. Thank you.

Sharing is caring!

Leave a Reply