Note 4 Not Recognized by Two PCs

General Help and How To
Hello Folks,

I have a Note 4 that I plan to install TWRP then a custom ROM on. Both Windows 10 & Linux Mint 20 do not recognize the phone. I enabled developers options, then enabled USB debugging. I first noticed this when I tried to copy the TWRP.tar file via Odin. The device doesn’t show up.

This is allegedly a brand new phone.

There is no popup dialog box on the device when I plug it into either computer. The battery icon up in the tray of the device does have a charging sign, yet no option for file transfer.

However, When I connect a different Note 4 to either computer, it registers fine. In Thunar File Manager on the Linux PC there is a connection icon for the other Note 4 that says, Samsung Galaxy. Also, on that device itself there’s a dialog box that pops up & asks for a file transfer. So this other device fine.

So, it seems both computers are OK. The problem is with the new phone. I’ve tried different USB cables & get the same issue. I’ve enabled & disabled the developer options & USB debugging & rebooted the device, & same thing. I’ve also tried a factory reset, that doesn’t fix it.

When I search the internet for this issue the only things I’ve found are reports on swapping USB cables & making sure that USB Debugging is enabled.

Any suggestions would be appreciated.

Thanks

Source

Sharing is caring!

Leave a Reply