Phone Won’t Go To Sleep (Oppo Reno 2Z, Android / Colours 11)

Uncategorized
Hi everyone, I’d appreciate any help you could give for an issue with my Android phone.

I recently bought a refurbished Oppo Reno 2Z. It’s a couple of years old, and was running Colours 7 or 8 when I got it. (Colours being the Oppo version of Android.) It’s updated a few times since then and is currently running Colours OS 11.1 / Android 11. However, I’ve been having a problem recently, which didn’t exist when the phone wasn’t updated (though I can’t be 100% certain that it was caused by the updates).

My phone screen won’t turn off. It starts to go dark, then momentarily turns black, then immediately comes back to life. It goes through this process over and over again. Initially, it only happened when I was playing music. Then it also happened whenever the phone was on charge at night (so I just placed it facedown). Today it became constant. If I press the sleep button, the lock screen lights up a second later.

Btw, I almost never see the always-on display anymore, which I set to a clock. Occasionally it does appear, but I’m never sure why. It’s sometimes the clock I set when I got an update for that, and sometimes the phone’s original always-on clock.

I’ve played with a lot of settings trying to figure out what’s causing this – the updates, or a specific app maybe – but so far haven’t found anything. I also contacted Oppo customer service, who made these suggestions (which didn’t work):

1. Disable the off-screen clock
2. Change the screen-off time
3. Back-up and reset my system settings, restart, enter recovery mode, reboot, set my auto screen off time again
4. Go into developer mode and check whether "keep screen on while charging" is enabled (it wasn’t)
5. Enable "sleep standby optimization"
6. Turn off developer settings and restart my phone (it wasn’t turned on anymore)
7. Perform a factory reset (I don’t want to do that, because I don’t want to lose my data and I’m not sure it would fix this.)

Thanks in advance, I appreciate it 🙂

Sharing is caring!

Leave a Reply