Pixel uses Google Voice if calling from Messages

I’m using a Pixel 5 — The stock Messages app always defaults phone calls to Google Voice. If I use the Phone app, it uses my carrier (Verizon) as it should. (Under "Settings/Calls & SMS" I have both set to Verizon.)

The situation is this: If you open a message thread from a person, there is a little phone icon at the top to allow you to call the sender of the message. If I click that icon, it always uses my Google Voice number, not Verizon.

Is there a setting to turn this off somewhere?

Sharing is caring!

Leave a Reply