Please help! Do Not Disturb Mode not working (unable to turn off notifications)

Uncategorized
Hi,

I recently purchased a Samsung Galaxy 21. I would like to be able to block calls from anyone not in my contacts, and I’d also like to be able to turn off notifications for voicemails (i.e. when someone leaves me a voicemail, I do not want a notification about it).

I was able to do both of these things on my old phone, which was a Samsung Galaxy 8. On that phone, I used an app called Blacklist Plus to block all calls from anyone not in my contacts, which worked successfully (unfortunately it doesn’t work on my Galaxy S21, I already tried). And I was able to go into the settings on my S8 to turn off notifications for Voicemails.

On my Galaxy S21, I am completely unable to turn off notifications for Voicemails. When going into the "Settings" and "Notifications" section of my S21, there is a slider for Voicemail notifications – but I am unable to turn the slider to "off" (the slider appears black and white, and I can’t slide it to off).

I was able to turn notifications off for "Visual Voicemail," but not for the "Phone" app (I get voicemail notifications from the "Phone" app).

I even tried "Do Not Disturb" Mode. I changed the settings so that only contacts could get past the "Do Not Disturb" Mode, but shockingly this didn’t work at all (non-Contacts can still call me). Furthermore, it did nothing to prevent me from getting notifications about Voicemails.

Any help whatsoever would be very much appreciated. I get a ton of spam calls – so many to the point that I prefer to just block all numbers that aren’t in my contacts, and I prefer to just never go into my voicemails.

Thank you
Dave

Sharing is caring!

Leave a Reply