Text Messaging with Dual Sim

Uncategorized
Hey all,

I have a Galaxy s20 (SM-G980F), and use dual sim for work/personal.

When I first used this setup last year, while texting, there would be 2 separate icons representing both sims that I could chose which sim to send the text – which was fantastic.

It seems that with an update on my phone, this option is no longer there. Going into sim manager, I can select "always ask" when selecting default sim for phone calls, but there is no such option for texts, it is just one or the other.

Even selecting a specific contact, I can set to call from one specific sim, but not for messaging.

What ends up happening is that a lot of the time, a text would be sent from the incorrect sim – making for a really frustrating experience.

Not sure what the thinking is here, but it is flat put a worser experience. I contacted Samsung, and they just sent a standard response back telling me to go into sim manager and select "always ask" under both calls and messages, when telling them I have the options for calls and not messages, I received another automated response back telling me the same thing, so I thought I would try my luck on here.

Has anyone else had this issue, and what, if anything, did you do to fix?

Thanks!

Sharing is caring!

Leave a Reply